Results 1 to 9 of 9
  1. #1

    2006 Impala SS Oil Consumption

    I am looking for info on abnormal oil consumption for my grandfathers 2006 Impala SS. It is a very early build 2006 going from memory. It is using enough oil in between changes that the low oil warning light is turning on. The local chevy dealer is claiming that 1 quart of oil every 1000 miles is normal and its just due for an oil change. It is sitting right at 3000 miles since the last oil change. Now my Grandpa is 85 years old, and I have a feeling they are just trying to avoid fixing whatever is wrong. These are the questions I have.

    How many quarts low is it when the warning indicators on the dash start going off. My grandpa said the dipstick was nearly dry when he checked it today. I am going over in the morning to check it over better.

    Everything I have read says at most for normal oil usage is 1 quart in 3000 miles at most not 1 quart every 1000 miles. Is this true?

    Thanks in advance the help.

    Tom
    2011 Lincoln MKS AWD

  2. #2
    BCM Cruiser
    Join Date
    May 2009
    Location
    West Allis, WI
    Posts
    211
    That was the first generation of those Impalas, I've heard a lot of different complaints on naioa.com (North American Impala Owners Association) I have an '06 with the 3.9l engine, I know mine doesn't burn that much oil, usually I have to add a quart between changes, not 3.
    But you might find some answers on that site.

    DASRED - West Allis, WI

  3. #3
    Chrysler Certified Technician Plum Crazy's Avatar
    Join Date
    Aug 2008
    Location
    Weather forecast for tonight: dark. Continued dark overnight, with widely scattered light by morning
    Posts
    1,359

    1qt of oil consumed every 1000 miles Under 50,000 miles is considered acceptable


    1qt every 500 miles over 50,000 miles is also considered acceptable.



    If my car was eating that much, id be demanding it be torn down and rebuilt.

    My brother had an 07 Monte SS for a while, it ate 1 qt a year (ran AmsOil in it)
    2010 Dodge Challenger R/T Classic Plum Crazy Purple
    2003 Dodge Dakota Quad Cab Flame Red
    1967 AMC Ambassador Convertible

  4. #4
    R.I.P. BCM Jawashoot Champion Toby and Kiki Champion GTSLOW's Avatar
    Join Date
    Apr 2003
    Location
    Fort Knox, Kentucky
    Posts
    13,174
    I know my GOV is a '07 Imp with the V6 and that thing eats oil too. Not sure about the 5.3L tho.
    All posts from the above author are expected to be 100% BS. Thank you and have a nice day.

  5. #5
    RIP Dad 4-29-08 brotherbenn83's Avatar
    Join Date
    Dec 2007
    Location
    Muskego
    Posts
    1,076
    There are bulletins for : Overactive DOD lifters (literally spray oil 5 feet when car cranked with valve cover off) and for leaking valve covers, allowing oil into pcv system where it is burned in the cylinders. We have also had a few re-ringed...this is also an issue with new style C/K trucks.
    GM World Class Certified Technician

  6. #6
    Cars are stupid VroomPshhTsi's Avatar
    Join Date
    May 2004
    Location
    In a car bed
    Posts
    2,308
    Is this an Impala SS specific problem?

    I read lots of reviews online of people have problems with their Impala SS with the LS4 but it didn't seem to cross over to the Monte Carlo SS or GP GXP.
    Daily Driver: 2009 Camry
    Weekend Car: 2006 Corvette

  7. #7
    Ok, thanks for the info guys. Its got 3200 miles since last oil change and was 2 quarts down. I am just not used to this at all. My Vic does not use a drop of oil. I was more shocked that it used enough oil to fire off the Driver info center Low Oil warnings.

    This car is an 11/05 build 2006 Impala SS. Someone on another forum told me that that the early 06 cars left the factory with the wrong oil cap and it should state that it needs synthetic oil. Is there any truth to this rumor?

    Tom
    2011 Lincoln MKS AWD

  8. #8
    Cars are stupid VroomPshhTsi's Avatar
    Join Date
    May 2004
    Location
    In a car bed
    Posts
    2,308
    Quote Originally Posted by VroomPshhTsi View Post
    Is this an Impala SS specific problem?

    I read lots of reviews online of people have problems with their Impala SS with the LS4 but it didn't seem to cross over to the Monte Carlo SS or GP GXP.
    Anyone?
    Daily Driver: 2009 Camry
    Weekend Car: 2006 Corvette

  9. #9
    I'm not honestly sure. One would think that the Monte SS would have same issues. Weren't they built on the same line as the Impala? I really don't know if the GP's were built in same place or not.

    As for my Grandpas car, I Seafoamed it, then had the oil changed and synthetic put in it. Gonna watch it really close the next 3000 miles and if its still using a ton of oil I will take it in for them. Sucks the warranty is gone though. 35,500 miles but well over the 3 years.
    2011 Lincoln MKS AWD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •